+0,47 und trotzdem verloren

Schon wieder Ärger. Per Mail hab ich heut früh erfahren, das meine Blog URL redirected wird auf Metamark http://xrl.us/kk3w6.
Grummel grummel
Kurze Kosmar Anfrage ergab den Verdacht auf ein WP Loch (bei meiner 2.1.3 Installation). Also Wp 2.6 geladen und versucht upzudaten – Fehlanzeige. Über Filezilla ließ sich der Ordner, indem WP liegt, ums verrecken nicht öffnen.
Bluthochdruck, Herzrasen, Webrocker angerufen – den netten WP-Gott aus der Nachbarschaft.

Nach kurzer Erläuterung fallen die Logindaten und obwohl (oder gerade weil) die Seite bei ihm normal angezeigt wird, findet Tom ein paar Klicks später fiesen Javacode.
Ich hatte Besuch von der 124 217 253 8, die sich gegen [17/Jul/2008:08:51:35 +0200] in meiner header.php rumgetrieben hat und die ich bis dato noch in keiner Whois bank gefunden habe..

Noch ein paar Klicks später hatte Tom das Problem beseitigt und ich konnte annähernd problemlos (ach diese index.php ist wichtig?) updaten.

Und jetzt hab ich die Scheisse: alle Umlaute sind am Arsch und alle Kategorien sind irgendwie verschwunden – oder zumindest nicht mehr lesbar.
Wahrscheinlich hat das Ding noch jede Menge mehr Macken, aber ich hab die Seite jetzt zugemacht – dafür ist heut echt keine Zeit mehr. Der Drecks-Hacker-Bot hat mich eh schon Stunden gekostet heute. Ich bin jetzt 0,49 Versionsnummern höher, um zwei Stunden und reichlich Nerven ärmer und das Blog sieht total zerschossen aus.

Danke an Kosmar für den ersten Hinweis und diesen Link, vor allem aber Danke an Tom für wahren Beistand.

Tipps und Aufmunterungen bitte per Kommentar.

Nachtrag: Nicht mal mehr links kann ich setzen und Bilder einfügen, die ganze scheiss Buttons sind nicht da – WP 2.6 sieht nicht nur scheisse aus …

Nachtrag 2: okay, die Umlaute hat es nur beim letzten Beitrag zerschossen, aber der Rest Ärger bleibt.

5 Kommentare zu “+0,47 und trotzdem verloren”

  1. Webrocker

    Hi Peter,
    ruhig Blut. :-)
    Damit die Kategorien wieder gehen, muss Dein Theme an die neuen WP-tags angepasst werden, die DB hasteja beim Update schon angepasst. Umaute ist fisseliger, aber auch lösbar. Wenn ich heute nachmittag Zeit finde, kann ich Dein Theme WP 2.5++ kompatibel machen, ansonsten nächste Woche.
    Das Update war auf jeden Fall richtig und wichtig!
    gruss
    Tom

  2. Marco

    > Trost
    > Beistand
    … mehr davon am Sonntag ;)

  3. Tom

    So Meister, Deine Kategorien sind wieder da. :-)
    Viele Grüße und ein entspanntes Wochenende wünsche ich!

  4. peter

    ich preise den Helden der Kategorien – und danke ihm.

    Und jetzt ist auch die Leiste zum Bilder/Links posten, fett und kursivn schreiben und alles wieder da .

  5. Webrocker

    Nachtrag zu meinem obigen Kommentar fürs Archiv: Das Theme war völlig in Ordnung, es hat tatsächlich datenbankseitig die Kategorien zerhauen beim Update, und das scheint wohl öfters vor zu kommen:
    pottblog.de – Kategorien weg
    blog.cumps.be – fix missing categories
    Ich habe die Kategorien manuell in der DB wieder hergestellt, anhand der IDs in einem Backup von kurz vor dem Update. Ohne das Backupfile hätte das nicht funktioniert.

    Also obacht an alle, die von einer früheren Version updaten – unbedingt Backups vorher machen!

sag auch was dazu: